Là gì

Vpn Tunnel Là Gì ? :: ViệT Anh Song Ngữ

Trong bài viết nàychúng ta cùng tìm hiểu GRE Tunnel là gì? Cách cấu hình GRE Tunnel trên Router Cisco và sử dụng công nghệ IPSEC Tunnel để mã hóa dữ liệu trên Tunnel

GRE là gì?

GRE là viết tắt củaGeneric Routing Encapsulation,là giao thức được phát triển bởi Cisco, cho phép đóng gói nhiều loại giao thức lớp Network trong các liên kết Point-to-Point. Một GRE Tunnel được sử dụng khi các gói dữ liệu cần được gửi giữa các mạng khác nhau thông qua internet. Với GRE được cấu hình, 1 đường hầm ảo được tạo giữa 2 Router và các gói tin gửi giữa 2 mạng nội bộ sẽ được truyền qua GRE Tunnel.

Đang xem: Tunnel là gì

Điều quan trọng cần lưu ý là các gói tin truyền trong GRE Tunnel không được mã. Để bảo vệ dữ liệu, chúng ta cần sử dụng công nghệ IPSEC kết hợp với GRE.

*

IPSEC GRE Tunnel về cơ bản giống với IPSEC VPN Site to Site khi cả 2 giao thức đều tạo 1 tunnel để kết nối giữa 2 site cho phép truyền dữ liệu qua chúng. Nhưng điểm khác biệt cơ bản là GRE Tunnel cho phép các gói tin Multicast trong khi IPSEC VPN thì không hỗ trợ. Trong các mạng lớn chạy các giao thức định tuyến như OSPF, EIGRP, bạn cần dùng GRE Tunnel để hỗ trợ các gói tin trao đổi giữa các giao thức này.

READ  Bài Thuyết Trình Về Bảo Vệ Môi Trường Xanh Sạch Đẹp Là Những Việc Làm Cụ Thể Gì

Các bước cấu hình

Bước 1: Bật giao diện Tunnel và đặt IP cho giao diện nàyBước 2: Tạo định tuyến tĩnh để cho phép các mạng nội bộ 2 Site có thể truy cập được lẫn nhau.Bước 3: Cấu hình IPSEC để mã hóa dữ liệu trên Tunnel

Cấu hình GRE Tunnel trên Router Cisco

Trong mô hình gồm có 2 Site là HQ và BR sử dụng NAT để truy cập internet. Site HQ gồm 2 VLAN: VLAN10-10.0.0.0/24 và VLAN20-10.0.1.0/24. Site BR gôm 1 VLAN 172.16.1.0/24. Router HQ có IP Wan là 100.0.0.100 và Router BR có IP Wan là 100.0.0.1. Yêu cầu bài Lab là cấu hình GRE Tunnel dải 192.168.1.0/24 để cho phép các VLAN giữa 2 site HQ và BR có thể truy cập được lẫn nhau.

Xem thêm: Kiếm Tiền Trong Pubg Mobile, Cách Người Trẻ Việt Nam Chi Tiền Cho Pubg Mobile

*

Bước 1: Tạo GRE Tunnel trên Router HQ

HQ#configure terminalHQ(config)#interface tunnel 0%LINK-5-CHANGED: Interface Tunnel0, changed state to upHQ(config-if)#ip address 192.168.1.1 255.255.255.0HQ(config-if)#tunnel mode gre ipHQ(config-if)#tunnel source100.0.0.100HQ(config-if)#tunnel destination 100.0.0.1

Trong phần tunnel source có nhiều tùy chọn như interface, IP address… các bạn có thể sử dụng các tùy chọn khác nhau. Bên cạnh đó mtu mặc định là 1500 byte nên nếu các bạn kết nối internet qua giao thức PPPoE thì các bạn cần cấu hình thêm mtu để tránh phân mảnh gói tin.

Bước 2: Tạo GRE Tunnel trên Router BR

Tương tự chúng ta tạo Tunnel trên Router BR

BR#configure terminalBR(config)#interface tunnel 0%LINK-5-CHANGED: Interface Tunnel0, changed state to upBR(config-if)#ip address 192.168.1.2 255.255.255.0BR(config-if)#tunnel mode gre ip
BR(config-if)#tunnel source100.0.0.1BR(config-if)#tunnel destination 100.0.0.100

Bước 3: Cấu hình định tuyến tĩnh để các VLAN giữa 2 site có thể kết nối được với nhau

Sau khi cấu hình interface tunnel giữa 2 router, chúng ta có thể ping được từ địa chỉ IP 192.168.1.1 trên Router HQ sang 192.168.1.2 của Router BR.

HQ#ping 192.168.1.2Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 msHQ#

Tuy nhiên lúc này các VLAN giữa 2 site vẫn không thể truy cập được lẫn nhau do router vẫn sử dụng Default route để định tuyến các gói tin này. Chúng ta cần tạo thêm định tuyến tĩnh để cho Router đẩy gói tin thông qua GRE Tunnel.

Xem thêm: Sơ Lược Về Thị Trường Vận Tải Là Gì ? Lựa Chọn Không Nên Bỏ Qua Cho Bạn

Cấu hình định tuyến tĩnh trên Router HQ

HQ(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2

Cấu hình định tuyến tĩnh trên RouterBR

BR(config)#ip route 10.0.0.0 255.255.255.0 192.168.1.1BR(config)#ip route 10.0.1.0 255.255.255.0 192.168.1.1

Bây giờ 2 site có thể ping thông được lẫn nhau thông qua GRE Tunnel

Mã hóa dữ liệu trên GRE Tunnel với IPSEC

Như mình đã đề cập ở trên, GRE là 1 giao thức đóng gói nhưng không mã hóa dữ liệu nên dễ bị bắt capture dữ liệu trên đường truyền. Vì vậy chúng ta phải kết hợp IPSec để mã hóa dữ liệu trong tunnel.

Bước 1: Cấu hình ISAKMP (IKE)

HQ(config)#crypto isakmp policy 1HQ(config-isakmp)#encryption 3desHQ(config-isakmp)#hash md5HQ(config-isakmp)#authentication pre-shareHQ(config-isakmp)#group 2

Bước 2: Cấu hình key để xác thực

HQ(config)#crypto isakmp key tranminhdung.vn address 100.0.0.1

Bước 3: Tạo chuyển đổi IPSEC

HQ(config)#crypto ipsec transform-set SET1 esp-3des esp-md5-hmacHQ(cfg-crypto-trans)#mode transport

Bước 4: Cấu hình IPSEC

R1(config)#crypto ipsec profileGRE-IPSEC

Bước 5: Gán IPSEC vào VPN Tunnel

R1(config)#interface Tunnel 0R1(config-if)#tunnel protection ipsec profileGRE-IPSEC

Cấu hình tương tự trên Router BR

Trả lời

Back to top button